Audio normalization / replayGain
Closed, ResolvedPublic

Description

I would like to be able to apply a semi-automatic amplification effect to clips, similar to Audacity's: basically, a property dialog which boosts the volume but without allowing going off the peaks ("clipping"), unless the user unchecks the safety checkbox.

Imported from https://bugzilla.gnome.org/show_bug.cgi?id=594265

jeff claimed this task.Sep 5 2009, 8:38 PM
jeff created this task.
jeff added a subscriber: jeff.

Uploaded

As usual, my reaction is "we can do better than this" and "the user shouldn't have to care".

A similar idea i was having was in fact to:

  • scan the audio of used sources and figure out the RMS/peaks. If the file has tags indicating the RMS/peak volume, don't scan it but use those values (those would be the musicbrainz tags).
  • Automatically adjust by default the volume of sources so that they all have the same 'target' volume.

Using this, we could end up with a 'good-for-most-people' default volume, you would be able to properly hear the volume of all your clips/soundtracks, and then you would only have to fine-tune the result (like lowering the background sound for ex).

Comments ?

jeff added a comment.Sep 6 2009, 3:08 PM

Sounds good so far. I guess there will be cases when the user wants to manually adjust or something, but for most cases, it will be nice to have the camcorder's track (with actors' voices) automatically amplified so that it's not buried too much by the music.

But wouldn't this cause a risk of clipping when multiple sound tracks are combined (ex: autoadjusted voices and music being too loud together)?

The idea is to give a better *Default* volume for clips (instead of the default 0.8 we use right now). It won't stop users from adjusting the volume afterwards.

jeff added a comment.Mar 5 2010, 2:53 AM
  • Bug T2491 has been marked as a duplicate of this bug. ***
jeff added a comment.Mar 5 2010, 2:54 AM

In bug #T2491, the following was said:

Gstreamer already provides the 'replaygain' plugins, rganalysis, rgvolume, and
rglimiter, which could be used to implement this.

pitivi-maint triaged this task as Enhancement priority.Sep 5 2009, 8:38 PM
pitivi-maint claimed this task.
thiblahute removed pitivi-maint as the assignee of this task.Sep 16 2015, 1:41 PM
thiblahute added a project: Pitivi.
thiblahute removed pitivi-maint as the assignee of this task.Sep 16 2015, 1:45 PM
aleb renamed this task from "amplify" sound effect or normalization / replayGain to Audio normalization / replayGain.Feb 13 2016, 9:53 PM

GitLab Migration Automatic Message

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.gnome.org/GNOME/pitivi/issues/638.

csoriano1618 closed this task as Closed.Fri, Feb 23, 6:38 PM
csoriano1618 claimed this task.