Fix warnings on Gtk 3.22
Closed, ResolvedPublic

Description

(pitivi:3): Gtk-WARNING **: GtkHScrollbar 0x27e2950 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: GtkVScrollbar 0x27e2750 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: GtkOverlay 0x2d03b40 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: GtkBox 0x2d11580 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: PitiviUriVideoSource 0x2d182d0 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: pitivi+timeline+elements+VideoBackground 0x2d11840 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: pitivi+timeline+previewers+VideoPreviewer 0x282ce10 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: PitiviAudioUriSource 0x2d18150 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: pitivi+timeline+elements+AudioBackground 0x2d116e0 is drawn without a current allocation. This should not happen.

(pitivi:3): Gtk-WARNING **: pitivi+timeline+previewers+AudioPreviewer 0x2d18450 is drawn without a current allocation. This should not happen.

Details

Differential Revisions
D1473: render: Update zoom fit call
D1463: timeline: Avoid using deprecated classes
D1462: previewers: Force waveforms redraw when height changes
D1461: previewers: Fix thumb widgets never removed
D1460: previewers: Remove obsolete logic
D1459: previewers: Remove the thumb_height field
D1458: elements: Rename methods and parameters
D1457: elements: Remove unused clip parameters
D1456: elements: Remove static tooltip setting
D1454: utils: Apply zoomratio limits before comparing it
D1453: previewers: Remove AudioPreviewer.set_size method
D1452: previewers: Rename cleanup method
D1451: previewers: Format imports
D1450: elements: Consistent vertical placement of audio elements
D1449: elements: Queue for redraw only the KeyframeCurve
D1448: elements: Remove queue_draw call
D1446: elements: Get rid of more GTK warnings
D1445: elements: Remove method which does not do anything
D1444: elements: Clarify what's the parent in Clip.updatePosition
D1443: elements: Remove obsolete logic
D1442: flatpak: Update meson
D1441: build: Use GStreamer 1.10 by default
D1440: timeline: Remove the minimum height of the TimelineContainer
D1439: timeline: Use ScrolledWindow instead of Viewport
D1438: timeline: Make the size_group argument mandatory
D1437: timeline: Fix warnings about scrollbars
D1436: timeline: Set the layout's size only when needed
D1435: layer: Remove redundant code
D1434: layer: Remove initial height_request
D1433: layer: Merge LayerLayout into Layer
D1432: timeline: Make LayersLayout owner of its children
D1431: timeline: Clarify why the Timeline is an EventBox
D1430: timeline: Remove Timeline._layers
D1429: validate: Rename some files and add comments
D1428: validate: Show more info when gst-validate-launcher missing
D1427: validate: Use os.environ to set the environment variable
D1426: build: Pass all the GST_ and GTK_ environment variables
D1425: validate: Allow running the integration tests with make validate
D1424: validate: Correct Python version in files run by gst-validate-launcher
D1423: configure: Use \t to specify the tab character
D1403: timeline: Use a single separator widget between layers
D1402: layer: Consistent imports
D1401: layer: Make field local variable
D1400: layer: Remove unused box child from SpacedSeparator
D1399: timeline: Remove unuseful size_request call
D1398: previewers: Remove unused width/height fields
D1397: layer: Remove unused method
D1396: timeline: Add a method for updating the snapping distance
D1389: timeline: Move the zoom_fitted field to Timeline
D1388: timeline: Avoid redrawing the layers controls for no reason
D1387: medialibrary: Create the label for the project settings infobar once
D1386: timeline: Use Widget.translate_coordinates instead of custom operations
D1385: timeline: Use directly a set when finding clips under marquee
D1384: timeline: Get rid of adjustCoords
D1383: effects: Stop hiding scale0tilt
D1382: timeline: Move scroll logic closer to where it's used
D1381: timeline: Get rid of the h/vadj fields of the container
D1380: ruler: Remove hadj parameter
D1376: timeline: Remove obsolete transposeXY method
D1375: Get rid of sendFakeEvent methods
D1374: timeline: Remove unneeded calls
D1373: medialibrary: Move some logic to __get_thumbnails_from_xdg_cache
D1372: medialibrary: Fix check for small_thumb shrinking
git URI
https://github.com/aleb/pitivi.git#wip/phab/T7573-gtk
aleb created this task.Oct 6 2016, 2:59 PM
aleb moved this task from Backlog to In progress on the Pitivi (0.98) board.
aleb added a comment.Oct 8 2016, 2:47 PM

The hscrollbar/vscrollbar spam disappears when the adjustment of the "layout" is not passed to the scrollbars.

aleb set git URI to https://github.com/aleb/pitivi.git#wip/phab/T7573-gtk.Oct 12 2016, 9:38 AM
aleb claimed this task.Oct 12 2016, 10:03 AM
aleb added a comment.Oct 21 2016, 4:53 AM

I made some cleanup but I did not get to the bottom cause of the warnings. I started reimplementing the timeline container structure with regular widgets but I can't reproduce the warnings, so there is hope.

I'm currently focusing on this warning about the layer controls vbox which appears when the height of the timeline is less than the height of the layers. First thought is that the warning should not appear because we display the layer controls in a viewport.

(pitivi:3): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to underallocate PitiviTimeline's child GtkBox 0x2c2b6e0. Allocation is 1614x391, but minimum required size is 221x414.

Another thing to do would be to get rid of this method in Timeline and instead call __setLayoutSize() where it's needed so that the size is set before allocating the size.

def do_size_allocate(self, request):
    self.__setLayoutSize()
    Gtk.EventBox.do_size_allocate(self, request)
aleb closed this task as Closed.Oct 23 2016, 4:12 PM
aleb reopened this task as Open.Oct 23 2016, 4:13 PM
aleb moved this task from In progress to Needs review on the Pitivi (0.98) board.Nov 4 2016, 3:13 PM
aleb closed this task as Closed.Nov 11 2016, 6:18 PM
aleb moved this task from Needs review to Done on the Pitivi (0.98) board.Nov 11 2016, 6:23 PM

GitLab Migration Automatic Message

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.gnome.org/GNOME/pitivi/issues/1912.