Shift+drag messes up the first clip when the second is adjacent
Closed, ResolvedPublic

Description

Steps to reproduce:

  • Create a new project, add tears of steel,
  • Press the button to add two clips to the timeline
  • Shift+drag the first clip to the right, notice both clips move
  • Continue the shift+drag operation to the left, notice vertical blue bar flickering
  • Drag the 2nd clip to the left a bit, notice a transition clip is created with the video part longer than the audio part. They should be equal.


aleb created this task.Sep 3 2017, 12:06 AM
aleb added a comment.Sep 3 2017, 10:29 PM

When I re-load the attached xges project, the video and audio of the left clip have the same length, and I see this error:
0:00:15.808728411 3 0x2160760 ERROR gestimeline ges-timeline.c:2310:layer_auto_transition_changed_cb:<gestimeline0> Transition transitionclip39 could not be wrapped into an auto transition REMOVING it
This bug might be related to T7782.

aleb added a comment.Sep 4 2017, 10:03 AM

Seems to happen when using shift+drag, I'll try to find a list of exact steps.

aleb moved this task from Backlog to 1.0 on the Pitivi board.Sep 4 2017, 9:48 PM
aleb edited projects, added Pitivi (1.0); removed Pitivi.
aleb updated the task description. (Show Details)Sep 4 2017, 9:53 PM
aleb triaged this task as Normal priority.
aleb renamed this task from Clip seems to be longer than what the UI displays to Shift+drag messes up the clips.
aleb renamed this task from Shift+drag messes up the clips to Shift+drag messes up the first clip when the second is adjacent.
aleb assigned this task to thiblahute.Oct 25 2017, 8:08 PM

Please test with my patch from T7782

thiblahute moved this task from Backlog to Needs review on the Pitivi (1.0) board.Oct 31 2017, 8:15 PM
thiblahute moved this task from Needs review to Done on the Pitivi (1.0) board.Nov 7 2017, 1:28 PM
thiblahute closed this task as Closed.

GitLab Migration Automatic Message

This bug has been migrated to GNOME's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.gnome.org/GNOME/pitivi/issues/2095.